Trouble Starting Tutorials

Game development with Board Game Arena Studio
User avatar
Iggy
Posts: 3
Joined: 09 April 2011, 03:49

Trouble Starting Tutorials

Postby Iggy » 15 February 2017, 16:34

Hi. I originally tried out the BGA studio project a few years ago, and after taking a few online courses on coding I decided to try again. Unfortunately, I've hit a block almost right away. I started both the Reversi and Gomoku tutorials, and can't even figure out how to make the board show up. I've looked over the directions multiple times, and even copied over some old code from a previous Gomoku tutorial I did years ago (which has the board show up), but I still can't even get started because nothing other than minor text changes are showing up; I've uploaded the image files and followed the directions in the tutorials. I'm at a complete loss here, and the example files apparently no longer exist, so now I'm here asking for help. Anybody have an idea of where things went wrong for me?

User avatar
Morgalad
Posts: 85
Joined: 17 January 2017, 20:46
Contact:

Re: Trouble Starting Tutorials

Postby Morgalad » 15 February 2017, 16:50

Hi,


Here you have the tutorials, it seems that documents older than x years were removed... so some people are loosing them.

https://www.dropbox.com/s/rsd5r4v49xudp ... o.zip?dl=0

also you can use the "open source" page we have created to get some ideas:

http://en.studio.boardgamearena.com/#!d ... de_Sharing
Cheers...
Morgalad

Developer of: Incan Gold and Takara Island

User avatar
Iggy
Posts: 3
Joined: 09 April 2011, 03:49

Re: Trouble Starting Tutorials

Postby Iggy » 16 February 2017, 18:05

Hey, thanks for the help!

Unfortunately, even with the files I'm still encountering the same problem. Even when I copied the entire code for the css and tpl files for Reversi (as well as the img files, of course), the board still doesn't show up. Is there a step in the process that I'm missing? Some sort of button I have to press to update images or something?

fafa-fr
Posts: 76
Joined: 22 December 2013, 21:58

Re: Trouble Starting Tutorials

Postby fafa-fr » 16 February 2017, 19:27

Hi,

Iggy wrote:Some sort of button I have to press to update images or something?

No, but the problem could be related to some css rule(s) stored in your browser cache (or something like that). I started your 2 reversi studio projects, and the reversi board did show up in both of them. When you say that it doesn't show up, you're talking about ohlookreversi project?

User avatar
Iggy
Posts: 3
Joined: 09 April 2011, 03:49

Re: Trouble Starting Tutorials

Postby Iggy » 17 February 2017, 00:40

No, but the problem could be related to some css rule(s) stored in your browser cache (or something like that). I started your 2 reversi studio projects, and the reversi board did show up in both of them. When you say that it doesn't show up, you're talking about ohlookreversi project?


Wow, didn't know that CSS was stored like that. Certainly explains a lot. Well, that did it, thanks! And yes it's ohlookreversi (the last in a long list of goofy reversi/gomoku names).

User avatar
Morgalad
Posts: 85
Joined: 17 January 2017, 20:46
Contact:

Re: Trouble Starting Tutorials

Postby Morgalad » 19 February 2017, 02:02

Just simply CRTL+F5 on your browser after updating something on the template or the css to force the browser to re-download these files.
Cheers...
Morgalad

Developer of: Incan Gold and Takara Island


Return to “Developers”

Who is online

Users browsing this forum: No registered users and 2 guests