can't end game (hotseat) ?

Forum rules
Please DO NOT POST BUGS on this forum. Please report (and vote) bugs on : https://boardgamearena.com/bugs
Post Reply
Ditto11
Posts: 69
Joined: 31 March 2023, 19:14

can't end game (hotseat) ?

Post by Ditto11 »

Tried playing this game for first time (in novice, hotseat mode - not sure if that's affecting things).
and I can't seem to end game. Not sure if it's something I'm doing wrong, or a potential bug?

Game table # is: 442753398

As I'm just experimenting/learning in a turn-based, no time limit hotseat game, I'll leave the game in it's current state for investigative purposes :)

I have already used 1 helicopter lift, and game didn't end, and so I'm in process of using a 2nd, but still not ending and not sure what I should be doing differently ?

Checkilst:
- all 4 treasures captured - check.
- all players (2) on Fool's Landing - check.
- Fool's landing not flooded (not required, but bonus :) ) - check.
- Used helicopter lift - check.
- selected Fool's landing tile - check.
- selected both pawns - check.
- game prompts "Select destination tile" ... O.o Huh ?
- ok .. so I selected neighboring "Lost Lagoon" ...
- both pawns moved .. game continues ... :(

Ok, so moved back to Fool's Landing ...
Used a 2nd helicopter lift:
again .. both pawns on fools' landing ... both pawn's selected .. again it's asking for a destination tile ..

What do you have to do to trigger end of game when you have all 4 treasures ?
Am I missing something ?
Ditto11
Posts: 69
Joined: 31 March 2023, 19:14

Re: can't end game (hotseat) ?

Post by Ditto11 »

hmm, interesting .. just poking around more .. I decided to cancel the lift ..
when I retried the lift, and selected fool's landing ... it gave option to "are you ready to leave island" ?

so seems something was glitching and stopping that ... was probably hotseat .. as before when I played the lift, the hotseat tried to switch me over to other play just to let me know the other played played the heli lift card O.o I had to refresh the page to get focus back to active player to continue playing the lift.

So might be something weird with hotseat ..

seems to be working now .
Post Reply

Return to “Forbidden Island”